If your assets are not displaying in EquipmentShare Track, there are a few troubleshooting tips you can try below. 

  • Check Your Filters
  • Check Your User Role/Permissions
  • Clear Your Cache

1. Check Your Filters

  • From EquipmentShare Track, select Map from the left navigation menu. 
  • Select Filters. 

  • Check each section of Branch, Group, Asset Type, and Asset Status to make sure ALL is selected.

  • Select Apply Filters to return to the map to see your assets.

2. Check Your User Role/Permissions

A user is assigned a role in Track by your company's Manager or Owner

  • Certain roles within the system will have viewing permissions. For example, a User-role will not be able to see assets, unless those assets are assigned to the user in a Group. Click here to learn more information about roles. 
  • If you cannot see your assets, check with your company Manager or Owner to verify your permissions. 
  • If your Manager or Owner has confirmed your role does have viewing permissions and you still cannot view assets, please contact our Customer Support team at customerservice@equipmentshare.com

3. Clear Your Cache

Your browser tends to hold onto information, and over time it could cause problems with logging in or bringing up desired results within EquipmentShare Track. It's always a good idea to clear out the cache, or browser history, and clear cookies on a regular basis.

Here are instructions on how to Clear Your Cache.

If you try the above methods and still cannot see your assets, please contact our Customer Support team by selecting the chat icon on the bottom right. 


Did this answer your question?